And the fun continues as I continue to prep for my CCNA certificate.

Lab 17 – So many commands that but by the end I think that I got them all

  • #show ip route
  • #show ip protocols
  • #show ip rip database
  • #show eigrp neighbor
  • debug [protocol]
  • (config)# router [protocol] {number for eigrp and OSPF which I have not learned about yet}
    • (config-router)# network [IP] [subnet | reverse subnet] {area for OSPF}
    • (config-router)# no auto-summary — This is for testing purposes
  • ip route with AD setting for fall back route

After writing them down, there aren’t that many but it sure felt like it when using all of the different protocols and how the AD (Administrative Distance) prioritizes one protocol over another.

 

 

Section 18 Connectivity Troubleshooting

  • Extended ping – very nice tool that I was not aware of.
    • Enter “ping” without an address will bring up other options such as
      • Protocol [ip]
      • Target IP address
      • Repeat count [5]
      • Datagram size [100]
      • Timeout in seconds [2]
      • Extended commands [n]
        • Source address or interface
        • Type of service [0]
        • Set DF bit in IP header [no]
        • Validate reply data [no]
        • Data pattern [0xABCD]
        • Loose, Strict, Record Timestamp, Verbose [none]
        • Sweep range of sizes [n]
  • Extended Traceroute – started the same way but due to the difference in functionality the options differ
    • Protocol [ip]
    • Target IP address
    • Source address
    • Numeric display [n]
    • Timeout in seconds [3]
    • Prove count [3]
    • Minimum Time to Live [1]
    • Maximum Time to Live [30]

Section 18 Lab – Use ping and traceroute to discover which router is missing a static route

 

 

Section 19 IGP Interior Gateway Protocol Fundamentals

  • RIP
    • Distance Vector
    • Hop Count Metric
    • Max hop count is 15
    • Summarise routes to the classful boundary by default
      • This can cause issues so it is recommended to use the “no auto-summary” to ensure that routes are not changed in undesirable ways.  If left on making sure that the routes are confirmed correct.
      • Use “ip summary-address rip” to manually summarize route at the interface level
    • Perform ECMP (Equal Cost Multi Path)
      • 4 paths by default
        • Can it have more and can it be set to less?
    • Version
      • Version 1
        • Not usually used much as version 2 has many advantages
        • Uses Broadcast every 30 seconds
        • Does not support authentication
        • Does not support Variable Length Subnet Masking (VLSM)
      • Version 2
        • Use multicast address 224.0.0.9 instead of broadcast
        • Supports authentication
    • RIPng
      • Not covered but should know that it is for IPv6
    • Verification commands
      • #show ip protocols
      • #show run | section rip
      • #show ip route
      • #sho ip rip database
    • Default Route Injection
      • (config-router)# default-information originate
  • EIGRP (Enhanced Interior Gateway Routing Protocol)
    • Advanced Distance Vector routing protocol
    • Very fast convergence time
    • Multicast – sent to routers affected by the changes through bounded updates
    • ECMP 4 paths by default but can be increased to 16
    • Can perform unequal cost load balancing
    • Autonomous System (AS) Number
      • This is to enforce independent administrative domains, each router much have the same AS number to pass routing information but this allows separate administrative domains.
    • Use a wild card mask when specifying the subnet
      • If no subnet mask is specified a classful boundary will be used. Class A 0.255.255.255, B 0.0.255.255 or C 0.0.0.255 will be used.
    • The interface subnet is what will be advertised and not the network that was setup.
      • Example
        • EIGRP used network 10.0.0.0 does not share 10.0.0.0/8 but will share any interfaces that are shared in the 10.0.0.0/8 range.  So interface with IP range of 10.10.0.0/24 will be shared.
    • Router identify themselves with an EIGRP Router ID which is a form of an IP address
      • Being the highest IP address of any loopback interface or highest other IP address if no loopback exists.
      • You can manually specify the Router ID
      • Recommended to use Loopback or manually set the routed ID
        • Manual ID command: (config-router)#eigrp router-id [ID]
    • Commands
      • #show run | section eigrp
      • #show ip protocols
      • #show ip eigrp interfaces
      • #show ip eigrp neighbors
      • #show ip route

 

 

Section 20: OSPF – Open Shortest Path First

  • Link State routing protocol
    • Each router describes itself and its interfaces to its direct neighbors
    • Each router learns the full network
  • Used for large networks
  • Fast convergence time
  • Multicast
  • Open standard so used by most vendors, for this reason, it is the most common internal routing protocol used.
  • Uses Dijkstra’s Shortest path algorithm to learn the network.
  • OSPF uses LSA (Link State Advertisements) to pass on the routing updates
  • OSPF Router ID
    • Being the highest IP address of any loopback interface or highest other IP address if no loopback exists.
    • You can manually specify the Router ID
    • To change the Router ID the service will need to be restarted
    • Recommended to use Loopback or manually set the routed ID
      • Manual ID command:
        • (config)#router ospf [process ID]
        • (config-router)#router-id [ID]
  • Uses a wild card mask when specifying the subnet
    • A wild card mask has to be specified or it will error upon entry
  • OSPF Operations
    • Discover neighbors
    • Form adjacencies
    • Flood LSDB (Link State Database)
    • Compute the shortest path
    • Install best routes in the routing table
    • Respond to network changes
  • OSPF Packet Types
    • Hello – Used to find adjacent routers
    • DBD (DataBase Description) packets – Used for adjacent routers to tell each other the networks they know about.
    • LSR Link State Request – Used to populated missing info in the received DBD
    • LSA (Link State Advertisement) – Route Update
    • LSU (Link State Update) – List of LSA’s which should be updated, used during flooding
    • LSAck – LSA acknowledgment
  • OSPF commands
    • (config)#router ospf [Process ID]
      • Process ID does not have to match to work with the neighboring routers
      • Routes will however not be propagated to other routers in the network since the process ID does not match.
    • (config-router)#network [network ip] [subnet wildcard mask] [area]
      • Example
        • OSPF used network 10.0.0.0 does not share 10.0.0.0/8 but will share any interfaces that fall into the 10.0.0.0/8 range.  An example: interfaces with IP range of 10.10.0.0/24 will be shared.
    • #sh run | section ospf
      • show ospf in the running-config
    • Identification and troubleshooting commands
      • #show ip protocols
      • #show ip ospf interface brief
      • #show ip ospf neighbor
      • #show ip ospf database
      • #show ip route
    • Manual ID command:
      • (config)#router ospf [process ID]
      • (config-router)#router-id [ID]
    • Passive Interfaces
      • (config)#router ospf [process ID]
      • (config-router)#passive-interface [interface]
      • (config-router)#passive-interface [interface]
      • (config-router)#passive-interface default
        • set all interfaces to passive
      • (config-router)#no passive-interface [interface]
        • Turns on the interface to use OSPF
    • Default Route Injection
      • (config)#ip route 0.0.0.0 0.0.0.0 [gateway IP]
      • (config)#router ospf [process ID]
      • (config-router)#default-information originate
    • Bandwidth vs Clock Rate and Speed
      • Speed Command
        • Used for network interfaces 
        • if ‘speed 10’ is set it will only transmit at 10 Mbps
      • Clock rate command
        • Used for Serial interfaces physical transmit
        • Serial interfaces transmit at 1.544 Mbps by default
        • If ‘clock rate 64000’ is set if will physically transmit at 64 Kbps
      • Bandwidth command
        • Setting ‘bandwidth’ does not affect the physical transmission rate.
        • If you set the bandwidth to 50 Mbps on a FastEthernet interface, it will still transmit at the default 100 Mbps or the set ‘speed’
        • ‘Bandwidth’ command affects software policy on the router
          • EIGRP
          • OSPF
          • QoS
        • It can influence software policy by setting the bandwidth on an interface.
    • OSPF Cost Metric
      • The router will learn about all destinations in its area and select routes based on its lowest to get to the destination.
      • Reference Bandwidth
        • Cost is automatically derived from the interface bandwidth.
          • Cost = Reference Bandwidth/Interface Bandwidth
            • Default reference bandwidth is 100 Mbps
            • FastEthernet link cost defaults to 1 (100/100)
            • t1 link cost defaults to 64 (100/1.544)
          • The reference bandwidth should be changed on all routers to compensate for speeds faster than FastEthernet otherwise all interfaces will be seen as a cost of 1
            • (config) #router ospf 1
            • (config-router)#auto-cost reference-bandwidth 100000
      • Manipulating the OSPF Metic
        • If manipulation is needed it is recommended to change OSPF cost on interfaces opposed to bandwidth as changing bandwidth can affect features other than OSPF such as QoS.
        • Cost change commands
          • (config)#interface [interface]
          • (config-if)#ip ospf cost 50
        • To review OSPF cost commands
          • #show ip ospf interface
            • To see full details for all interfaces
          • #show ip ospf interface [interface]
            • To see an individual interface
          • #show ip ospf interface brief
            • To see a summary of all interfaces

Another day in the book.  I am on week three but I have a feeling since I am not just reviewing OSI model items and now focusing on Cisco commands along with the Cisco Functionality I will be working more closely with the timeline that is laid out on the study plan calender.

 

 

1 thought on “Cisco CCNA Study – Day 3

Comments are closed.